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Learning Outcomes  

By the end of this unit the learner will be able to: 

✓ Create formulas in a worksheet 

✓ Insert functions in a worksheet 

✓ Reuse formulas 
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UNIT 02 PERFORMING CALCULATIONS 

Create Formulas in a Worksheet 

EXCEL FORMULAS 

Formulas are mathematical expressions that operate on cell contents. When cells contain 

numerical data, you can perform multiple mathematical operations on the cell content as your 

worksheet requires. The results of these operations will be shown in the cell that contains the 

formula. Formulas can be simple, like adding two cell values, or quite complex, involving 

multiple mathematical operations. 

THE FORMULA BAR 

Located just below the ribbon, the Formula Bar is where you will type in functions for a selected 

cell: 

 

 

The Formula Bar is comprised of the Name Box(1); the Insert Function,Enter, and 

Cancelbuttons(2);and the Formula Bar text box (3):  

 

 

The Formula Bar text box will display the contents of the selected cell and allow you to edit its 

contents. The Insert Function button allows you to insert functions that you type into the 

Formula Bar into the currently selected cell. The Enter button will enter any formula that 

appears in the bar into the current cell, while the Cancel button will cancel the process and 

clear the Formula Bar entirely.  

ELEMENTS OF AN EXCEL FORMULA 

Formulae are always preceded by an equals sign (=). Formulae can contain cell references (like 

A1), numbers (like 23), or functions (like SUM(B2:B9)). Enter a formula by typing directly into a 

cell or into the Formula Bar: 
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=A1+23, = d2-c2, and =B10+b11/C6 are all valid formulae; cell references are not case-sensitive. 

 

If you include a cell reference in a formula (like =B3*6), and that cell reference itself contains a 

second formula (like =B1+B2, stored in B3), that second formula (=B1+B2) will be evaluated 

first, and the result will be used in =B3*6. 

 

You can tell if a cell contains a formula by making it active. If there is a formula in the active cell, 

it will be shown in the Formula Bar: 

 

 

 

COMMON MATHEMATICAL OPERATORS 

Excel uses eight basic mathematical operators: 

 

Name Symbol Example 

Exponent ^ 10^2 = 100 

Multiplication * 10*2 = 20 

Division / 10/2 = 5 



 

Microsoft Excel 

Addition + 10+2 = 12 

Subtraction - 10-2 = 8 

Equivalence = 10 = 10 

Greater Than > 10>2 

Less Than < 2<10 

 

THE ORDER OF OPERATIONS 

The common mathematical operators shown above are listed from top to bottom in order of 

precedence. This means that Excel does not simply calculate expressions from left to right; 

certain operations are performed before others. Multiplication and division, addition and 

subtraction, and the greater than/less than operations each have equal precedence.  

You can impose your own order of operations by enclosing expressions in parentheses (). The 

operations inside the parentheses will be evaluated before the operations outside.  

If you have parentheses within parentheses, such as ((2+3)*4), the expression in the inner 

parentheses, (2+3) =5, will be evaluated first, and the result will be used to evaluate the 

expression in the outer parentheses, (5*4) =20. 

One easy way to remember precedence order is to remember the word “BEDMAS,” which 

stands for Brackets (aka Parentheses), Exponents, Division, Multiplication, Addition, and 

Subtraction. Note that: 

▪ Division and Multiplication have equal precedence, calculated from left to right. 
▪ Addition and Subtraction have equal precedence, calculated from left to right. 

 

ACTIVITY 2-1 

Creating Formulas in a Worksheet 

You have been given a spreadsheet that requires a basic formula to calculate the total sales 

based upon the number of products that were sold. You will use the tools covered in this topic 

to complete this task. 
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1.  To begin, open Excel 2016 and open Activity 2-1 from your Exercise Files folder: 

 

 

  

2.  Ensure that Sheet1 is displayed. Cells A2 and A3 in this sheet have very similar formulas 

but display very different results. Click each cell and look in the Formula Bar to find the 

difference: 

 

 

  

3.  As you can see, the parentheses completely change the result of this formula. Let’s move 

on to Sheet2:  
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4.  This sheet contains a basic table with a few formulas calculating the data. Click cell C2 to 

see how it is calculated: 

 

 

  

5.  Click cell C3 to see how it is calculated: 

 

 

 

Which method do you think is better? 
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6.  Use the preferred method to calculate row 4. Don’t forget to press Enter or click the 

Enter button beside the Formula Bar after entering the formula: 

 

 

  

7.  Now, click in cell C5 and type: =SUM(C2,C3,C4). Watch how your text appears in the 

Formula Bar and how the calculated cells are identified: 
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8.  Press Enter to calculate the formula: 

 

 

  

9.  Now, notice that Excel has identified cell C8, which does not use a proper formula, with a 

green triangle: 
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10.  Click this cell to display the Error option button. Click the Error option button and click 

“Copy Formula from Above:” 

 

 

  

11.  The formula from the cell above will now have been copied to the currently selected cell 

and updated to reflect the new adjacent rows (A3 and B3): 

 

 

  

12.  Save the file as Activity 2-1 Complete and then close Excel. 
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Insert Functions in a Worksheet 

FUNCTIONS 

Functions are pre-made operations that are used to perform calculations. Excel features a 

number of functions relating to basic math, financial applications, logic, date and time, and 

more. 

For example, if you want to add a column of ten numbers, you could type =A1+A2+A3+…etc., 

but that would quickly become tedious and would also make the spreadsheet harder to work 

with. A much more efficient way of performing this calculation is to use the SUM function: 

 

 

 

In this example, we typed “=SUM(“ and then added the A1 to A10 cell range (A1:A10). Upon 

added a closing parenthesis and pressing Enter, the sum of all these numbers was calculated 

and displayed (55). That is much easier than typing out a very long formula and allows for more 

flexibility if additional rows are added within the defined range. 

THE FUNCTION LIBRARY 

Functions have been a very important part of Excel right from the beginning because they make 

data computation and analysis very easy. In fact, Excel features over 300 built-in functions to 

calculate or provide information regarding: 

▪ Databases 
▪ Date and time 
▪ Engineering 
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▪ Finance 
▪ Worksheet metadata 
▪ Logic 
▪ Lookup and reference 
▪ Math and trigonometry 
▪ Statistical analysis 
▪ Text strings 

 

You can browse the nine categories available in the Formulas tab: 

 

 

 

You will likely use many of the functions available under AutoSum, Financial, and Math & Trig. 

Remember to check the Recently Used menu to look at functions you have used in the past. 

COMMON FUNCTIONS IN EXCEL 

Using the AutoSum button, you can quickly insert some of the more commonly used functions 

into a worksheet. The followingbasic mathematical and statistical analysis functions are 

included:  

 

Name Usage 

Sum Add values together in a specified range or argument. 

Average Determine the average value in an argument. 

Count 

Numbers 

Determine the number of cells that contain a specific 

value in a specified cell range. 
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Max Find the highest of the values in an argument. 

Min Find the lowest of the values in an argument. 

 

The AutoSum Button 

To use the AutoSum command, click the cell immediately below (if summing a column of data) 

or to the immediate right (if summing a row of data) of the data you want to sum.Next, click 

Formulas →AutoSum: 

 

 

 

(Additional functions are available by clicking the drop-down arrow.) Excel will scan the data in 

the column/row. The column or row of data to be summed will be highlighted by an animated 

border: 
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Press Enter to complete the AutoSum command: 

 

 

 

THE FORMULA AUTOCOMPLETE FEATURE 

The Formula AutoComplete feature allows you to type function names directly into cells. While 

typing the formula name, the matching functions will filter themselves based on what you have 

entered. Click a function to use it: 

 

 

 

Once you have decided on a function to use, Excel will prompt you to enter each argument as 

necessary. Add the closing parenthesis, press Enter, and Excel will calculate the value: 
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ACTIVITY 2-2 

Inserting Functions into a Worksheet 

You have been given sales numbers for the past two years. Using functions, you need to 

calculate the average income, expenses, and profit from this data. As well, you need to 

calculate the profit that each manager in the company has generated.  

 

13.  Open Activity 2-2 from your Exercise Files: 
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14.  Select D4:D27. You should see the Average (along with Count and Sum) appear in the 

status bar: 
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15.  Select D29 (Average Income) and then click Formulas → AutoSum→ Average: 
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16.  Excel will automatically insert the Average function and include a range up to the top of 

the column of data: 

 

 

  

17.  Press Enter to accept this value. The resulting value will now be shown: 
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18.  Repeat this action for Average Expenses (E31) and Average Profits (F33): 

 

 

  

19.  Now select cell I4. (Note that cells I4 and J4 have been merged.) 

 

 

  



 

Microsoft Excel 

20.  Click Formulas → AutoSum: 

 

 

 

(Don’t click the pull-down arrow.) 

  

21.  By default, Excel will want to sum cells D4:H4. However, this is not what you want to do: 

 

 

  

22.  Use your cursor to click and drag over cells F4:F8 to select the cells associated with Bob: 
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23.  Bob was acting manager for more than this time, so add a comma after the previously 

selected cell range and select F26:F27: 
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24.  Press Enter. The total profits from when Bob was acting manager will now be displayed 

in the previously selected cell: 

 

 

 

(Note that the closing bracket will be added automatically when you press the Enter key 

or click the Insert Function button on the Formula Bar.) 
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25.  Repeat these steps for Jill and Brad’s data using the relevant ranges of data from the 

Profit column: 

 

 

 

(You can select separate ranges of data at the same time by holding down the Ctrl key.) 

  

26.  Save the file as Activity 2-2 Complete and then close Excel. 

Reuse Formulas 

THE CUT, COPY, AND PASTE COMMANDS 

Just like many applications that you work with, Excel allows you to move and/or copy cells and 

their contents to other areas of workbook or even other applications. You can move a cell or its 

contents using the Cut and Paste commands. If you wanted to copy a cell and its contents 

instead, you could use the Copy and Paste commands. You can find all of these commands in 

the Clipboard group of the Home tab:  

 

 

 

These commands are also available on the right-click menu. 
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Keyboard Shortcuts 

In addition to the commands in the Clipboard group of the Home tab, you can also perform the 

Cut, Copy, and Paste commands using keyboard shortcuts. To use the Cut command, press Ctrl 

+ X. Copy is performed by pressing Ctrl + C, and Paste is performed by pressing Ctrl + V. 

 

PASTE SPECIALOPTIONS 

Paste Specialcan be a very useful Excel feature when trying to move data and objects around in 

your workbooks, as well as move them to and from other applications. Paste Special’s options 

can be used to perform a lot of operations that might be tedious to perform using other Excel 

tools.Paste Special does indeed paste data, but it also allows you to perform operations on the 

destination cells using the pasted data. 

 

Consider the following worksheet. It lists quantities in column A, prices in column B, and sales 

(A*B) in column C: 

 

 

 

Suppose that all prices are to be raised by 20%. You can manually enter the new prices, use a 

formula in a new column to calculate the prices, or you can use Paste Special.  

 

To use Paste Specialin this situation, enter the value 1.2 (the numerical equivalent of 120%) in 

cell D1. Then, right-click D1 and click Copy: 
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Next, select the prices in column B.Right-click on the selected area and clickPaste Special: 

 

 

 

 

This will display the Paste Specialdialog box: 
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There are a number of options In the Paste Specialdialog box that you can choose from. To 

increase the prices in the selected range by 20%, we want to multiply each price in the selected 

range by 1.2. Therefore, select the Values and Multiply radio buttons and then click OK: 

 

 

 

Returning to the worksheet, you will see that the prices have now been increased by 20%, and 

Sales have increased as well, taking the new prices into account. The currency formatting 

applied to column B also remains: 
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Note that you can access some additional paste options by clicking the Home → Paste drop-

down menu:  

 

 

 

Or, by right-clicking a destination on the worksheet and moving your cursor over the Paste 

Special sub-menu:  
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RELATIVE REFERENCES 

Worksheets are composed of rows (horizontal, referenced with numbers) and columns 

(vertical, referenced with letters). The intersection of each row with a column forms a cell, and 

each cell is given a name in the “ColumnRow” format. These are called relative referencesand 

are typically the most commonly used type of reference in Excel. Such references are flexible in 

that they change depending upon the position of the formula. 

ABSOLUTE REFERENCES 

While relative references are fine for many, if not most situations,if data moved around or 

copied using AutoFill, relative cell references can create incorrect and confusing results. To 

avoid this, absolute cell referencesare used. These references use dollar signs ($) to make sure 

a formula always references the same location, no matter where it is moved.  

 

You can assign absolute cell references in three ways: 

▪ $Column$Row: Both the row and column designation won’t change ($A$1). 
▪ $ColumnRow: The column designation won’t change, but the row can ($A1). 
▪ Column$Row: The row designation won’t change, but the column can (A$1). 
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MIXED REFERENCES 

Mixed references are cell references that include a mix of absolute and relative references. For 

example, $ColumnRow ($A1) is a mixed reference because while the column designation is an 

absolute reference, the row designation is relative. Additionally, Column$Row (A$1) is also a 

mixed reference because the row designation is an absolute reference, while the column 

designation is a relative reference. 

ACTIVITY 2-3 

Reusing Formulas 

While working on a workbook, you discover that you need to adjust the prices of a variety of 

products by 10%. Additionally, you need to duplicate the values in column D to another area of 

the worksheet.  

 

27.  Open Activity 2-3 from your Exercise Files: 
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28.  Right-click D1 and click Copy: 

 

 

 

The copied cell(s) will have a flashing border. 

  



 

Microsoft Excel 

29.  Right-click H1 and click the Paste button which is highlighted below:  

 

 

 

This will copy the “Units sold” heading to this location. 

  

30.  Cell D1 will still have a flashing border. Click anywhere outside cell D1 and H1 and press 

Ctrl + D to deselect the cell. Now select the D2:D8 cell range: 

 

 

 

Press Ctrl + C to copy these cells. 
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31.  Click H2 and press Ctrl + V to paste: 

 

 

 

Click outside the pasted area and press Ctrl + D to deselect the values in column D. 

  

32.  Click E9 to select it. Move your mouse pointer to one of the cell borders. The pointer will 

turn into a four-headed arrow:  
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33.  Click and drag this cell one column to the right: 

 

 

 

 

  

34.  The cell will look like this: 

 

 

 

This is an error stating that the value in this cell is too wide to be shown due to the 

column width. 
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35.  Move your mouse pointer to the divider between columns F and G, and then click and 

drag to the right: 

 

 

  

36.  If you make the column a bit wider, the value will reappear: 

 

 

  

37.  Add the number 1.1 to cell A2 and press Enter: 
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38.  Click to select cell A2 and press Ctrl + C to copy this cell. Now select cells C2:C8: 

 

 

  

39.  Right-click these selected cells and click Paste Special: 
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40.  When the Paste Special dialog box appears, click the Multiply radio button and then click 

OK: 

 

 

  

41.  All values will be multiplied by the value in A2, and thus will change the value of column 

E and cell F9: 
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42.  With cells C2:C8 still selected, reapply the account number format by clicking Home → 

Number Format → Accounting:  

 

 

  

43.  Your worksheet will now look this:  

 

 

  

44.  Save your file as Activity 2-3 Complete and then close Excel. 

 


