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Learning Outcomes  

By the end of this unit the learner will be able to: 

✓ Manipulate data 

✓ Insert, manipulate, and delete cells, columns, and rows 

✓ Search for and replace data 

✓ Spell check a worksheet 



 

Microsoft Excel 

UNIT 03 MODIFYING A WORKSHEET 

 Manipulate Data 

THE UNDO AND REDO COMMANDS 

Like in many other applications, the Undo command allows you to reverse the last action that 

you completed. The Redo command, on the other hand, will cancel the last Undo action. Both 

of these commands are available on the Quick Access toolbar:  

 

 

 

Additionally you can also perform the Undo command by pressing Ctrl + Z on your keyboard 

and the Redo command by pressing Ctrl + Y.  

The Undoand Redo commands both include a drop-down list that will display recently 

completed actions that you can undo or redo: 

 

 

 

Note that while you can undo most actions in Excel, there are a few exceptions. For example, 

you cannot undo the save action.  
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THE AUTOFILL FEATURE 

The AutoFill feature can help you quicklyenter repeated or incremental text and numbers. For 

example, imagine that you have to enter all of the years from 1990-2010 in a worksheet. Rather 

than typing each year manually, you can take advantage of the AutoFill feature to enter the 

data quickly and easily.  

 

In order to use AutoFill, you need to establish a pattern. For this example, we will type 1990 in 

one cell and 1991 immediately below. Then we will select both cells: 

 

 

 

Next, we will click and drag the small square down the worksheet until the desired value is 

reached. Once “2010” appears beside the mouse pointer, we’ll release the mouse button and 

Excel will automatically fill in the numbers: 
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The worksheet will now contain the years 1990-2010.  

 

This feature doesn’t just work on single increments either. You can have Excel jump 2, 10, or 

10,000 numbers at a time, forwards or backwards, depending on the two initial values you have 

entered. Excel also comes pre-programmed with some other common AutoFill sequences, 

including days of the week and months of the year, that do not require you to enter two 

consecutive values. 

AUTOFILL OPTIONS 

For more control over how AutoFill operates, click the small icon in the bottom right-hand 

corner of the AutoFilled data: 
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AutoFill options include the following: 

▪ Copy Cells: Copy the selected cells into the AutoFilled area. 
▪ Fill Series (default option): AutoFill the pattern of the selected cells. 
▪ Fill Formatting Only: Apply only the formatting to the AutoFilled area. 
▪ Fill Without Formatting: AutoFill the pattern of the selected cells while ignoring any 

formatting. 
▪ Flash Fill: AutoFill the column with data when it senses a pattern. 

Other AutoFill Options 

Note that the options that are shown in the AutoFill options menu can change depending upon 

the type of data in the first cell in the range of cells that you were working with. For example, 

suppose that the first cell showed any day of the week. This would cause the AutoFill options 

menu to display the Fill Days and Fill Weekdays options:  
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These options allow you to choose between including and excluding the weekend from the 

series that you are creating. 

THE TRANSPOSEOPTION 

The Transpose option is a type of Paste command that includes options to shift the vertical and 

horizontal orientation of any columns and rows in a worksheet. For example, suppose that you 

had a data range that displayed product namesand numbers as rows, with days of the week 

displayed as columns: 

 

 

 

You could transpose the columns and rows bycopying this data range and then placing your 

cursor on the worksheet where you want the copied data to be pasted. Next, click Home → 

Paste → Transpose: 
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The result will flip the row and columns:  
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LIVE PREVIEW 

Live Preview is used to give you an idea of how copied objects will look when pasted in a 

selected area using regular paste or a Paste Specialoption. These previews are enabled by 

default and will be displayed automatically when you place your cursor over a paste option on 

the Paste drop-down command or the Transpose paste option on the context menu:  

 

 

 

A preview of how the data will look when pasted will now be displayed and any overlaying 

menus will become transparent.  

You will also find this feature when formatting your worksheets by changing fonts and adding 

styles. We will discuss this aspect of Live Previewfurther in Lesson 4. 
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THE CLEAR BUTTON 

One or more selected cells can be cleared of formatting, data, comments, or hyperlinks by 

clicking Home → Clear → [object type]: 

 

 

 

Alternatively, you can clearall of these objects at once by clicking Home → Clear → Clear All.  

QUICK ANALYSIS FEATURES 

Quick Analysis provides easy access to Excel’s data visualization and management tools, and 

helps you use them. To start, select the data in question and click the Quick Analysis icon in the 

bottom right corner: 

 

 

 

(Note that you can also use the Ctrl + Q shortcut.) 
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The Quick Analysis pane will open. Choose a category from the top of the pane and a specific 

style or tool from the middle of the pane: 

 

 

 

You will see a preview of each item as you hover over it: 

 

 

 

(Notice the left and right arrows in the middle part of the pane, which allow you to view more 

tools in this category.) Click a tool to apply it or close the pane by clicking back in the Excel 

window. 
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ACTIVITY 3-1 

Manipulating Data 

You need to create a worksheet that will display the number of products sold on average by the 

product and the day of the week. You have gotten a good headstart on it, but you need to 

change a few things using the tools that you learned about in this topic. 

 

1.  To begin, open Activity 3-1 from your Exercise Files folder:  

 

 

  

2.  First, you need to use the AutoFill feature to complete the sequence that shows the days 

of the week as column headers. Click to select cell B1 and then move your cursor to the 

bottom right corner of that cell so that it is on top of the small square:  
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3.  Next, click and drag the small square to F1:  

 

 

 

(Note that a ScreenTip will show you the day that will be entered into this cell.) 

  

4.  Release your mouse button. You will see that the sequence has been completed:  

 

 

  

5.  Next, you need another copy of this data but with the columns and rows transposed. 

Use your cursor to select the A1:F5 cell range: 
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6.  Press Ctrl + C to copy this data:  

 

 

  

7.  Click cell A7 and then click Home → Paste → Transpose: 

 

 

 

(Note that you will see a preview of how this data will lookafter it is pasted when you 

hover over the Transpose command.) 
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8.  The selected data will now have been pasted with the columns and rows transposed 

from the original copy:  

 

 

  

9.  Remove the bold formatting from cells B7:E7 by selecting them and then clicking Home 

→ Clear → Clear Formats: 
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10.  You will see that the bold effect has been removed from the selected cells:  

 

 

  

11.  Save your work as Activity 3-1 Complete and close Microsoft Excel 2016. 

 Insert, Manipulate, and Delete Cells, Columns, and Rows 

THE INSERT AND DELETE OPTIONS 

To insert a column in a worksheet, right-clicka column header and click Insert. This will add a 

new column in this location and push all existing information (including the column you right-

clicked) one column to the right. 

Here, you can see that a new column is being inserted between columns B and C: 
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A new empty column is now ready to be worked with: 

 

 

 

This procedure is the same for inserting rows. To insert a row, right-click a row header and click 

Insert: 

 

 

 

All of the data in the row you selected as your insertion point, and the data in the rows beneath 

it, will be shifted down one row. This will leave an empty row where you can enter new data: 
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Deleting rows and columns works in the same way.To delete a column, right-clickthe column 

header you want to remove and click Delete. All of the data to the right of the column will be 

shifted one row to the left, and the old information will be replaced with the data that was in 

the column to the immediate right.To delete a row, right-click the row header and click 

Delete.All of the data below the row will be shifted up one row, and the old information will be 

replaced with the data that was in the row directly beneath. 

To insert a single cell, right-click a cell and click Insert: 
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The Insertdialog box will appear: 

 

 

 

When you insert a cell, the existing data must be relocated. Selecting “Shift cells right” in this 

dialog box will move the item in the active cell, and all the items to the right of it, one cell 

further to the right, leaving a blank cell at the original location. For example, if you added a new 

cell at A1 the data in cell A1 would move to B1, the data in B1 would move to C1, and so on, 

leaving cell A1 empty.Selecting “Shift cells down” will perform a similar operation, but a 

downward direction. For example, if you inserted a cell at location B1, the data in B1 would 

shift to B2, B2 would shift to B3, and so on, leaving B1 empty. The“Entire row”or “Entire 

column”options allow you to insert a row or a column in the same manner we just discussed. 

 

The Insert and Delete commands can also be found on the Home tab: 

 

 

 

COLUMN WIDTH AND ROW HEIGHT ALTERNATION METHODS 

Sometimes it will be necessary to change the size of a row or column in order to display all the 

data contained in the cell.You also might want to change the size of a row or column just for 

appearance. In either case, resizing a row or column is quite easy. 

To change the size of a column, place your mouse pointer on the line that divides the column 

headers. For example, if you wanted to change the size of column B, you would place your 
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mouse pointer on the line separating B and C. Your cursor will turn into a vertical line with a 

small arrow on either side: 

 

 

 

When you see this pointer, click and hold the left mouse button todrag the column edge to the 

left or right. As you drag you will see the size (default width is 64 pixels): 

 

 

 

When you release your mouse, the size of the columnwill be changed. 

 

To change the size of a row, place your pointer on the line separating the row headers and then 

click and drag up or down to make the row larger or smaller (default height is 20 pixels): 
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There are more resizing commands available by clicking Home → Format: 
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THE HIDE AND UNHIDE OPTIONS 

Excel also gives you the ability to temporarily hide particular rows, columns, or sheets and then 

unhide them when necessary. To begin, select the row or column that you want to hide, or 

make the target sheet active. Then, click Home → Format → Hide & Unhide, and choose the 

desired option: 
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In this example, you can see that row 3 is hidden: 

 

 

 

To re-show it, we would re-select the surrounding rows and click Home → Format → Hide & 

Unhide → Unhide Rows: 
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Note that the Hide and Unhide commands are also available on the right-click menus for rows, 

columns, and sheets. 

ACTIVITY 3-2 

Manipulating Columns and Rows 

You have been given a large spreadsheet that contains information about the sales personnel in 

your company. There are few changes that you need to make to make this data more reader-

friendly and to highlight the data that is most important to you. 

 

12.  To begin, open Activity 3-2 from your Exercise Files: 

 

 

  

13.  Let’s start by resizing some of the columns. Select cell B1. Click Home → Format → 

AutoFit Column Width: 

 

 



 

Microsoft Excel 

  

14.  Column B will now be resized to fit its data. You can also see that the Sales column (E) is 

too small for its data. Double-click the separator between the E and F headers to fix this: 
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15.  Next, you need to add subtotal rows for each month. Right-click the header for row 7 

and click Insert: 
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16.  Type the word “TOTAL” in the new cell A7 and press Enter.Then, apply the Bold effect by 

re-selecting the cell and pressing Ctrl + B on your keyboard: 

 

 

  

17.  Click anywhere in row 15 and click Home → Insert → Insert Sheet Rows: 
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18.  Type the word “TOTAL” in the new cell A15 and apply the bold text effect: 
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19.  For March, type the word “TOTAL” in A22 and again apply the bold text effect: 
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20.  Finally, let’s hide the Bonus column. Do this by first selecting the G column using its 

header: 

 

 

  

21.  Next, click Home → Format → Hide & Unhide → Hide Columns: 
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22.  Save your work as Activity 3-2 Complete and close Excel. 

 

Search For and Replace Data 

CELL NAMES AND RANGE NAMES 

Rather than using cell references (e.g. A1:C1), you can apply descriptive names to cell ranges. 

Range names are not case sensitive, cannot contain spaces, and cannot start with a number. 

To apply a cell name or range name, first use your cursor to select the cell(s) that you want to 

name. Next, type the name that you would like to use into the Name Box:  
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Pressing Enter will apply this name. From then on, you will be able to select this range by 

clicking the Name Box drop-down menu and clicking on the range name that you set: 

 

 

 

To remove a cell name or range name, select the cell(s) in question and then clear the name out 

of the Name Box. Press Enter and the name will be removed. 

THE FIND COMMAND 

The Find command is used to locate information or data within the current workbook. The Find 

and Replace dialog has lots of options on the Find tab to help with this task: 

 

 

Here is an overview of the commands in this dialog box. 

▪ The “Find what” drop-down menu allows you to display any items that were recently 
searched for.  

▪ The Options button will expand this dialog and show you more search options, like 
matching text case. 
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▪ The Find All button will actually execute the search command and look for all instances 
of the search terms within the workbook.  

▪ The Find Next button, on the other hand, will allow you to search for the next 
occurrence of the search term. Clicking it again will highlight the next occurrence, and so 
on.  

 

Accessing the Find Command 

To access theFind and Replace feature, click Home → Find & Select → Find, or press Ctrl + F: 

 

 

 

 

 

 

 

 

 



 

Microsoft Excel 

Either action will display the Find and Replace dialog box with the options hidden by default: 

 

 

 

If you click the Options button, you have more choices to refine your search: 

 

 

 

You can now choose to search formatting, within a sheet or workbook, in rows or columns, or 

by matching the case, all by making selections in the combo boxes. 

Advanced Search Options 

The Find and Replace dialog contains some powerful advanced search options that you can use 

to find exactly what you are looking for in a workbook.  

▪ Clicking the Format button will open the Find Format dialog. Here, you can specify the 
exact format type that you would like to search for.  
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▪ The Format drop-down menu allows you to choose a format to look for based upon an 
existing cell.  

▪ The Within drop-down menu allows you to choose between searching the current 
worksheet or the entire workbook.  

▪ The Search drop-down menu is used to specify if the search should be performed by 
row or column.  

▪ The “Look in” drop-down menu is used to specify if you want to search formulas, values, 
or comments. 

▪ The “Match case” checkbox allows you to specify whether you want the results of your 
search to match the exact text case of your search terms.  

▪ Similarly, the “Match entire cell contents” checkbox will only return results that are the 
exact and complete characters of the search terms. 

 

THE REPLACE COMMAND 

If you click the Replace tab in the Find dialog, you have the option to search for a term and 

replace it with something else: 

 

 

 

(You also can jump directly to this tab by pressing Ctrl + H or by clicking Home → Find & Select 

→ Replace.) 

If any instances of the search criteria entered in the “Find what” text field are found, they can 

be replaced with whatever is in the “Replace with” text field. All you have to do is click the 

Replace button each time Excel finds something. 

 

If you click the Replace All button, Excel will replace every instance of the word or number it 

finds with the replacement term, without waiting for you to click Replace for each one.  

 



 

Microsoft Excel 

Advanced Replace Options 

The Options button will show additional controls and commands that you can use to get more 

specific with your replace action: 

 

 

 

Find and Replace also lets you search for and replace certain types of formatting. First, click the 

Format button and click Format: 
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The Find Format dialog will open. Here you can select a format type from the tabs at the top 

and then specify the details of the format in the dialog. For example, if you choose the Number 

category you can select the type of number formatting that you want Excel to find. Click OK 

once you have set your options: 

 

 

 

(You can also choose a format from a cell by clicking the Choose Format From Cell button, 

which will allow you to click a worksheet cell that contains the desired formatting, and populate 

the dialog with those options.) 
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Once you click OK in the Find Format dialog, you will be returned to the Replace dialog box. You 

can choose a replacement format in the same way that you chose a format to find: 

 

 

 

In the second half of the dialog, there are options to search worksheets, workbooks, and 

formulas.Once your options are set, click Replace to replace the unwanted format one cell ata 

time, or click Replace All to perform all of the replacements at once. 

 

THE GO TO COMMAND 

To view the Go To window, click Home → Find & Select → Go To: 
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(You can also directly open the Go To dialog box by pressing Ctrl + G on your keyboard.) 
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Using this dialog box, you are able to quickly go to any named range within your workbook. For 

example, here you can see the “Headers” range that we can quickly go to and select:  

 

 

 

Clicking the Special button will display another dialog box that allows you to select cells based 

on chosen criteria. For example, you can choose blank cells, cell that contain comments, and 

much more:  
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(You can display this dialog box directly by clicking Home → Find & Select → Go To Special.) 

 

ACTIVITY 3-3 

Searching For and Replacing Data 

You have been put in charge of maintaining the Employee Absence Schedule. Your first task is 

to configure this worksheet and add employee names to the list. 

 

23.  To begin, open Activity 3-3 from your Exercise Files folder: 
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24.  First, you need to set up the employee names. Click Home → Find & Select → Replace: 

 

 

  

25.  The Find and Replace dialog box will now be displayed. In the “Find What” box, type 

“Employee 1.” In the “Replace with” box, type “Jill Marston.” Click Options: 
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26.  Click the Within menu and choose Workbook: 

 

 

  

27.  Click Replace All: 
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28.  Excel should inform you that it has made 12 replacements. Click OK: 

 

 

  

29.  Repeat Steps 3 through 6 to perform the following replacements: 

▪ Employee 2 = Sam Smith 
▪ Employee 3 = Teresa Martinez 
▪ Employee 4 = Jackson Motton 
▪ Employee 5 = Annabelle Ruiz  

 

Ensure that Excel is searching the entire workbook. Each search should result in 12 

replacements. 

  

30.  When you have finished the employee replacement, type “Employee Name” in both the 

“Find what” and “Replace with” fields. Click Format next to the “Replace with” field: 
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31.  The Replace Format dialog will now be open. Click the Font tab, and then choose Bold 

Italic for the font style. Click OK: 
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32.  Ensure that “Workbook” is still selected from the Within menu and click Replace All: 

 

 

  

33.  Excel will inform you that it has made 12 replacements. Click OK: 
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34.  Close the Find and Replace dialog by clicking the Close button: 

 

 

  

35.  Save your work as Activity 3-3 Complete and close Microsoft Excel 2016. 

 

Spell Check a Worksheet 

THE SPELLING DIALOG BOX 

To start checking the spelling and grammar in your workbook, first open the Spelling dialog by 

clicking Review → Spelling:  

 

 

 

(Note that you can also open this dialog by pressing F7 on your keyboard.) 
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You will likely be prompted to begin checking spelling at the beginning of the sheet (A1). Click 

Yes to continue: 

 

 

Any misspelled or unrecognized words will be displayed in the Spelling dialog box. Here’s an 

example: 

 

 

 

As you can see, the word “Wednesday” is misspelled and shown at the top of the dialog. There 

are two suggestions listed in the lower half of the dialog and a number of other commands: 

 

Ignore Once Ignore this particular instance and keep checking the rest of the 

worksheet. 

Ignore All Ignore all instances of the misspelled word and keep checking the 

rest of the sheet. 
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Add to Dictionary Add this particular word to Excel’s dictionary so each subsequent 

entry is listed as correct. This is useful for proper names. 

Change Change this particular instance of the misspelled/unrecognized word 

to whatever is currently highlighted in the Suggestions box. 

Change All Change all instances of the misspelled/unrecognized word to 

whatever is currently highlighted in the Suggestions box. 

AutoCorrect Click this button to have AutoCorrect automatically change this 

instance of the word to whatever Excel feels is correct.  

Options This will open the Excel Options dialog to the Proofing category. Here 

you can change AutoCorrect options and set additional corrective 

actions. 

UndoLast If you accidentally changed something with the previous 

misspelled/unrecognized word, click this button to revert that 

change and then continue checking the worksheet. 

Cancel Stop checking for spelling errors and close this dialog. 

 

When the checking is complete, click OK to return to your work: 
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ACTIVITY 3-4 

Spell Checking a Worksheet 

You have started constructing a worksheet. You want to make sure the spelling that you are 

using is correct. 

 

36.  To begin, open Activity 3-4 from your Exercise Files folder: 

 

 

  

37.  Ensure that you are on the first worksheet of the workbook. Click Review → Spelling: 
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38.  The word “Equipment” is spelled incorrectly. The Spelling dialog has selected the correct 

spelling, so click Change to continue: 

 

 

  

39.  Correct the next two errors in the same way: 
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40.  When Excel has finished checking the current sheet, click OK to close the spell checker: 

 

 

  

41.  Now let’s check the Income sheet. Switch to it by clicking its tab: 

 

 

  

42.  Click Review → Spelling to check this sheet: 
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43.  “Boths” is the only misspelled word on this sheet. There are several instances of this 

word on this sheet, so click Change All: 

 

 

  

44.  You will see a dialog stating the spell checking is complete. Click OK to continue: 

 

 

 

(If you are prompted to start checking at the beginning of the sheet, click No.) 

  

45.  Save your work as Activity 3-4 Complete and close Microsoft Excel 2016. 

 


